Error with billing service
Incident Report for Globalese
Resolved
The incident has been resolved
Posted Jan 10, 2024 - 17:52 UTC
Update
We are continuing to investigate this issue.
Posted Jan 10, 2024 - 17:52 UTC
Investigating
We identified problems with the billing service which is resulting in problems with translation services.
Posted Jan 10, 2024 - 17:01 UTC
This incident affected: Document translation and Text translation.